openWrt入门1——从虚拟机开始运行

  本人不才,在工作近2年中,还是有不少收获的,因为是有做网关设备,因此有学习到openWrt的一些知识。openWrt的官网:https://openwrt.org/。现在已经更新到12.09版本了。接下来,将分几篇文章,来说说openWrt吧。

openwrt10.03.1登录后台界面

  openwrt是什么?简单的说就是一个路由器系统,支持很多应用程序,现在使用的是linux的内核,最新版本12.09.可以快速的上手。并且自带了工具链的编译,img的生成,支持多种文件系统。可以搭建镜像源,使用opkg(与debian的dpkg差不多,或者应该说是dpkg的openwrt版本)进行保管理。具体详细的介绍,可以看看维基百科:http://en.wikipedia.org/wiki/OpenWrt (中文的WIKI没人维护吧,都没写什么内容,可以看看英文的)。

  openwrt可以在虚拟机中试玩,也就是x86版本。下载openwrt的vmware虚拟硬盘:openwrt-x86-generic-combined-ext4.vmdk。在vmware上创建个内存128的linux3.0内核版本的,如果需要,可以配置多个网卡,毕竟是路由器系统,这样模拟才真实,将对应的硬盘设置为下载的vmdk文件,硬盘要设置成IDE模式不然可能会起不来。虚拟机可以将没用的打印机,声音等的一些给移除。就可以开始运行openwrt了。

  首先需要做的,就是配置网络,openwrt通过UCI的方式来配置网络。网络的UCI配置文件为/etc/config/network,修改其中config  interface lan为以下的内容,也就是修改lan测的ip,有一点就是openwrt默认防火墙wan侧是不允许登录WEB以及后台的。添加个eth1,桥接的方式,用来上网用。

root@OpenWrt:~# cat /etc/config/network
# Copyright (C) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.160.110 # 与vmware的配置同个网段,我这边eth0为Nat模式,160网段。
option netmask 255.255.255.0

config interface wan
option ifname eth1
option proto static
option ipaddr 192.168.78.110 # 配置成对应的IP
option netmask 255.255.255.0
option dns 8.8.8.8 # 配置下DNS
option gateway 192.168.78.129 # 网关记得配置
root@OpenWrt:~# /etc/init.d/network restart
root@OpenWrt:~# ping baidu.com
PING baidu.com (220.181.111.85): 56 data bytes
64 bytes from 220.181.111.85: seq=0 ttl=51 time=252.481 ms
64 bytes from 220.181.111.85: seq=1 ttl=51 time=195.221 ms
64 bytes from 220.181.111.85: seq=2 ttl=51 time=197.273 ms
^C
--- baidu.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 195.221/214.991/252.481 ms

在宿主机上ping一下地址,ping通,就可以开始通过secureCrt来连接了,linux的话,可以直接ssh登录。但是首先,你需要在虚拟机的界面将root密码改掉。ping一下百度,成功,openwrt就可以成功联网了。

root@OpenWrt:~# passwd
Changing password for root
New password:
Bad password: too short
Retype password:
Password for root changed by root
root@OpenWrt:~#

openwrt支持空密码,我也习惯自己使用的时候使用空密码,方便连接。网络配置好后,就可以登陆后台,以及WEB界面了。修改密码后,直接点Login即可登录。

登陆界面
登陆界面
WEB界面
WEB界面

  之前已经说过,使用官方提供的vmdk,可以直接安装官方的二进制包。通过opkg来安装WEB中文语言包。

root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/x86/generic/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
root@OpenWrt:~# opkg install luci-i18n-chinese
Installing luci-i18n-chinese (0.11+svn9769-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/x86/generic/packages/luci-i18n-chinese_0.11+svn9769-1_x86.ipk.
Configuring luci-i18n-chinese.

到WEB下,System–>Language and Style–>Language –>chinese–>Save&Apply。刷新下界面,中文就出现了。

中文界面
中文界面

  至此,openwrt的入门1,就先到这里了,可以先折腾下opkg命令,安装些应用之类的了。

参考资料:

http://wiki.openwrt.org/doc/uci/network

http://wiki.openwrt.org/doc/techref/opkg?s[]=opkg

转载请注明: 转载自elkPi.com

本文链接地址: openWrt入门1——从虚拟机开始运行

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

Scroll to top